PS3を使ってMD5を演算できる?!

PS3とMD5ハッシュ値衝突の脆弱性との"危険な"関係 - SHA-2を代替関数に

LinuxやUnixなどのOSでは広く使われているMD5が完全に破られたみたいです。
使用されたのはプレイステーション3
記事によると「まったく同一のMD5ハッシュ値をもった、異なる候補者名が記載されたPDFファイル」と書いてあるので、完全に違うプログラム(ウイルスやマルウェアなど)を正規のプログラムとしてMD5認証させることが出来るみたいです。
気軽にapt-getやyumでアップデートするとウイルスを入れることにもなるかもしれません。おそろしや

MD5の脆弱性はだいぶ前から言われ続けていましたが、そろそろ本当に終了のようです。
同じく脆弱性のあるSHA-1も危ないですけどね。
今のところ安全なハッシュ関数はSHA-2って事ですかね。


PS3、本業のゲームでは不振ですが他の場所では本領発揮のようですw

| コメント(0) | トラックバック(0) |
■Yahoo!オークション おすすめ商品■
Web Services by Yahoo! JAPAN

トラックバック(0)

トラックバックURL: http://type-y.com/mt/mt-tb.cgi/328

コメントする